Lumen help

Configuration guidelines for On‑Demand services

Prepare for On‑Demand services

Basic configurations 

IP/data service configuration tips

Ethernet service performance 

Traffic shaping

Customer provided equipment (CPE) and cabling

Router configurations

Ethernet configuration guidelines

The following reference table provides basic Ethernet interface connectivity standards, cabling and compatibility. Customer edge (CE) device configuration guidance is provided for those Ethernet service speeds most commonly associated with performance issues.

InterfaceMedia type handoffFiber modeBandwidth usage limitDistance limit
1000 Base SXFiberMulti‑mode1 Gbps220m–550m
1000 Base LX/LHFiberSingle‑mode1 Gbps10km
1000 Base ZXFiberSingle‑mode1 Gbps70km
10000 Base SRFiberMulti‑mode10 Gbps220m–550m
10000 Base IR/LRFiberSingle‑mode10 Gbps10km/20km
40G Base LRFiberSingle‑mode40 Gbps20km


Ethernet crossover cables (Switched services)

Example VLAN configurations

All On‑Demand services require VLAN tagging to separate services between the Lumen port and your CPE. Some services require double tagging to nest VLANs within other VLANs. The following examples will help you get started creating a VLAN with On‑Demand services. 

  • A router port in Dallas is directly connected to the Lumen switch UNI. The configuration connects two Ethernet On‑Demand point‑to‑point spokes (St. Louis and Seattle) and one EVC for Internet On‑Demand.  

Customer router example configuration for Cisco:


interface GigabitEthernet0/0/1

 description Lumen UNI Dallas

!

interface GigabitEthernet0/0/1.101

 description EoD EVC to Saint Louis (Spoke 1)

 encapsulation dot1Q 101

 ip address [WAN IP address determined by customer]

!

interface GigabitEthernet0/0/1.102

 description EoD EVC to Seattle (Spoke 2)

 encapsulation dot1q 102

 ip address [WAN IP address determined by customer]

!

interface GigabitEthernet0/0/1.401

 description EVC to Internet on Demand (IoD)

 encapsulation dot1q 401

 ip address [WAN IP address assigned by Lumen]


Spoke 1 example configuration for Cisco:


interface GigabitEthernet0/0/1

 description Lumen UNI Saint Louis

!

interface GigabitEthernet0/0/1.101

 description EVC to Dallas

 encapsulation dot1Q 101

 ip address [WAN IP address determined by customer]


Spoke 2 example configuration for Cisco:


interface GigabitEthernet0/0/1

 description Lumen UNI Seattle

!

interface GigabitEthernet0/0/1.102

 description EVC to Dallas

 encapsulation dot1Q 102

 ip address [WAN IP address determined by customer


  • A switchport in Dallas is directly connected to the Lumen switch UNI. The configuration connects two Ethernet On‑Demand point‑to‑point spokes (St. Louis and Seattle) and one EVC for Internet On‑Demand.  

Customer switch example configuration for Cisco:


interface e0

switchport trunk allowed vlan 100,200

switchport trunk encapsulation dot1q

switchport mode trunk


interface e1

switchport access vlan 100

switchport mode access


interface e2

switchport access vlan 200

switchport mode access


interface e3

switchport access vlan 200

switchport mode access



Router 1 example configuration for Cisco:


interface GigabitEthernet0/0/1

 description Lumen UNI Saint Louis

!

interface GigabitEthernet0/0/1.101

 description Router to Switchport e1

 ip address [WAN IP address assigned by Lumen]

  • A router port in Dallas is directly connected to the Lumen switch UNI. The configuration connects an Ethernet On‑Demand point‑to‑point service to a CSP that requires Q‑in‑Q configuration to terminate a single VLAN to the CSP using two distinct end‑to‑end paths. The egress must account for four extra bytes of overhead for double tagging. Therefore, the MTU on the port facing the UNI must be set to at least 1504.   

Customer switch example configuration for Cisco:


interface GigabitEthernet0/1

 description Lumen UNI Dallas – Primary

 mtu 1504

!

Interface GigabitEthernet0/1.10125

encapsulation dot1Q 101 second‑dot1q 25

description “Cloud Connection Primary Peer”

Ip address 10.103.224.217 255.255.255.252

interface GigabitEthernet0/2

 description Lumen UNI Dallas ‑ Secondary

!

Interface GigabitEthernet0/2.20125

encapsulation dot1Q 201 second‑dot1q 25

description “Cloud Connection Secondary Peer”

Ip address 10.103.224.221 255.255.255.252

  • A router port in Dallas is directly connected to the Lumen switch UNI. The configuration connects an Ethernet On‑Demand point‑to‑point service to a CSP that requires Q‑in‑Q configuration to terminate a single VLAN to the CSP using two distinct end‑to‑end paths. The switchport facing the UNI must be a trunk that allows the VLANS to pass. The switchports that interface with the CSP must be configured to access VLAN so the outer tags can be placed in the frame. Q‑in‑Q on the outbound port must allow multiple secondary tags encapsulated in the outer tag. The egress must account for four extra bytes of overhead for double tagging. Therefore, the MTU on the port facing the UNI must be set to at least 1504.   

Customer switch example configuration for Cisco:


interface e0

switchport trunk allowed vlan 101,201

switchport trunk encapsulation dot1q

switchport mode trunk

mtu 1504


interface e2

switchport access vlan 101

switchport mode dot1q‑tunnel


interface e3

switchport access vlan 201

switchport mode dot1q‑tunnel


Device 1 example configuration for Cisco: 


interface GigabitEthernet0/1

 description Lumen UNI Dallas – Primary


Interface GigabitEthernet0/1.25

encapsulation dot1Q 25

description “Cloud Connection Primary Peer”

ip address [WAN IP address determined by customer/CSP


Device 2 example configuration for Cisco:


interface GigabitEthernet0/2

 description Lumen UNI Dallas – Secondary


Interface GigabitEthernet0/2.25

encapsulation dot1Q 25

description “Cloud Connection Secondary Peer”

ip address [WAN IP address determined by customer/CSP]


Alternate Option to run the switch as trunks and perform Q‑in‑Q on a layer 3 device connected to the switch: 


interface e0

switchport trunk allowed vlan 101,201

switchport trunk encapsulation dot1q

switchport mode trunk

mtu 1504


interface e1

switchport trunk allowed vlan 101,201

switchport trunk encapsulation dot1q

switchport mode trunk

mtu 1504


Router 1 example configuration for Cisco: 


interface GigabitEthernet0/1

 description Router to Switchport e1

mtu 1504


Interface GigabitEthernet0/1.10125

encapsulation dot1Q 101 second‑dot1q 25

description “Cloud Connection Primary Peer”

Ip address 10.103.224.217 255.255.255.252


Interface GigabitEthernet0/1.20125

encapsulation dot1Q 201 second‑dot1q 25

description “Cloud Connection Secondary Peer”

Ip address 10.103.224.221 255.255.255.252

Additional technical support

On‑Demand support